Rubyの環境構築

MacOSX(Lion)にはruby1.8.7がインストールされてるが、1.9系やらrvmやらをインストールしたくなったのでメモ。
https://rvm.io/rvm/install/を参考にrvmを入れる。
rvmとrubyを同時にインストールしたりできるらしいが、今回は別々で。

$ curl -L get.rvm.io | bash -s stable
$ source ~/.rvm/scripts/rvm
$ rvm -v
rvm 1.14.1 (stable) by Wayne E. Seguin <wayneeseguin@gmail.com>, Michal Papis <mpapis@gmail.com> [https://rvm.io/]

rvmはこれでおk。
次はrubyを入れる。
インストール可能なバージョンを確認。

$ rvm list known
# MRI Rubies
[ruby-]1.8.6[-p420]
・・・
[ruby-]1.9.3-preview1
[ruby-]1.9.3-rc1
[ruby-]1.9.3-p0
[ruby-]1.9.3-p125
[ruby-]1.9.3[-p194]
[ruby-]1.9.3-head
ruby-head

# GoRuby
goruby
・・・

最新の1.9.3をインストールする。

$ rvm install 1.9.3
$ rvm use 1.9.3
$ ruby -v
ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-darwin11.4.0]

一つ前のバージョンも入れてみよう。

$ rvm install 1.9.2
The provided compiler '/usr/bin/gcc' is LLVM based, it is not yet fully supported by ruby and gems, please read `rvm requirements`.

なんかダメらしい。。。
コンパイラーがサポートされてない?
rvm requirements?

$ rvm requirements

  Notes for Mac OS X 10.7.4, Xcode 4.3.2.
・・・
Xcode 4.3+ users
- please be warned
- only ruby-1.9.3-p125+ is partially supported
- in case of any compilation issues:
 * downgrade to Xcode 4.1
 * uninstall Xcode and install osx-gcc-installer
and reinstall your rubies.

rvmの意味なくね?

広告

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中

%d人のブロガーが「いいね」をつけました。